Email Delivery Outage

Incident Report for Ontraport

Resolved

Server back in place. Staying around to monitor for a little bit
Posted Oct 19, 2025 - 08:58 PDT

Identified

Our Edge Mailer Server hosting company had a unscheduled issue with their virtual machines. We're currently working with them to bring back our mailing IPs.
Posted Oct 19, 2025 - 07:56 PDT
This incident affected: Backend Services (Email Delivery).